[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4284: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4286: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4287: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4288: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
www.dhtmlgoodies.com • View topic - Tab Menu - Submenu's "flash" when loading
Advertisement

Tab Menu - Submenu's "flash" when loading

Moderators: Calcifer, slothy

Tab Menu - Submenu's "flash" when loading

Postby Alexx » Fri Mar 05, 2010 12:08 am

I have been using this script with a few modifications for about a year now, it's been great.

The only problem with it I have seen so far is that when loading say any picture the submenu's all collapse and are visible at once, then after it finishes loading they disappear and only the mouseover one remains.


I went back today and tested just the original version (http://www.dhtmlgoodies.com/index.html? ... es_tabmenu) and am getting the same results. Is there a way to stop the 'flash' persay while loading a page? I know with a frame it's doable but I really don't want to go down that road lol.
Alexx
 
Posts: 12
Joined: Mon Jul 27, 2009 5:08 am

Postby rayfy » Fri Apr 23, 2010 6:45 am

Hiya! Looks like I'm not the only one who's come across this problem.
Any chance you have found a resolve yet?

I isolated it down to just the pieces of code required to run it, and it doesn't come up with the problem until more content is added on to the page. It's most evident in Internet Explorer, but also becomes evident in Firefox with more content. (Must be the way Firefox prioritises things.)

I first thought it was an ordering issue in the html. So I placed the required scripts and css after the <head> tag, but the problem still occured.

Here's my example fyi.

I sadly don't have the skill set for doing this, but is there an actual way to prioritise loading these scripts up first? Or is there a way to modify the javascript so it hides the submenus until everything needed is loaded?
rayfy
 
Posts: 4
Joined: Fri Apr 23, 2010 6:25 am

Postby Alexx » Sat Apr 24, 2010 6:11 am

Nah, still wrestling with it a little here and there.

I did come across this idea from Batalf,

http://www.dhtmlgoodies.com/forum/viewtopic.php?t=9539

But it didn't work. I tried quite a few other combination's trying to tweak it but no luck so far.
Alexx
 
Posts: 12
Joined: Mon Jul 27, 2009 5:08 am

Postby Alexx » Sat Apr 24, 2010 6:47 am

Odd, I attempted it again it seemed to have worked lol

Think I put it wrong by one line actually though the first time, make sure to follow what he says exactly and it should work. I used the longcat picture to slow down the loading to test it and it passed.

Good luck.
Alexx
 
Posts: 12
Joined: Mon Jul 27, 2009 5:08 am

Postby rayfy » Mon Apr 26, 2010 3:32 pm

Genius! Thank you Alexx. It seems to do the job :)
rayfy
 
Posts: 4
Joined: Fri Apr 23, 2010 6:25 am

Postby anokhi » Sun May 16, 2010 4:48 am

I isolated it down to just the pieces of code required to run it, and it doesn't come up with the problem until more content is added on to the page. It's most evident in Internet Explorer, but also becomes evident in Firefox with more content. (Must be the way Firefox prioritises things.)

I first thought it was an ordering issue in the html. So I placed the required scripts and css after the <head> tag, but the problem still occured.
anokhi
 

Postby rayfy » Wed May 19, 2010 2:00 pm

rayfy
 
Posts: 4
Joined: Fri Apr 23, 2010 6:25 am

Postby vivan » Sat Jun 26, 2010 5:14 am

Nah, still wrestling with it a little here and there.

I did come across this idea from Batalf,
vivan
 
Posts: 1
Joined: Sat Jun 26, 2010 5:12 am

Postby rayfy » Sat Jun 26, 2010 1:55 pm

rayfy
 
Posts: 4
Joined: Fri Apr 23, 2010 6:25 am

Postby bhovika » Thu Jul 08, 2010 6:21 pm

bhovika
 
Posts: 1
Joined: Thu Jul 08, 2010 6:19 pm


Return to Menu script questions

Who is online

Users browsing this forum: No registered users and 3 guests

cron